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What is a digital image?
 Open X-ray.tif.X-ray.tif.X-ray.tif

You are looking at an X-ray image of major arteries in the neck and chest. 
The patient is facing you, although his head is turned to the side. Notice 
how the fi llings in the patient’s teeth are visible. The large loop at the 
bottom of the image is the aorta. When pictures like this are displayed on 
a computer screen, they are digital images. But, what exactly are digital 
images? How are they used, and what char ac ter is tics do they possess?

 Use the Magnifying Glass tool   to click on the image four or fi ve  to click on the image four or fi ve 
times to zoom in. (You can click  

 to click on the image four or fi ve  to click on the image four or fi ve 
  while holding down   while holding down Control

[Win] or Option [Mac] to restore the image.)

 1. What do you see?

The small squares that make up a digital image are called picture el e ments 
or pixels.

 Watch the status bar as you move the  tool across the pixels. tool across the pixels.

 2. What do you notice about the status bar? (Be specifi c!)

You should see numbers changing. The pixels in a digital image represent a 
grid or table of numerical values. Each pixel value is a single measurement 
recorded at a specifi c time and place. By assigning a specifi c color to each 
different pixel value, a picture or digital image is formed. An X-ray is an 
image made up of X-ray “brightness” mea sure ments. Where the X-rays are 
blocked, by bone for example, the brightness is low. Where the X-rays pass 
through, in substances such as air or soft tissue, the brightness is high. 
Scan ners and digital cameras collect these bright ness mea sure ments and 
display them as digital images.

With image pro cess ing technology you can analyze and change fea tures of 
pixels such as their brightness, contrast, or numerical value.

 Choose Image > Adjust > Brightness/Contrast to open the B&C
(Brightness & Contrast) window. Adjust each of the four slider 
controls, and watch how each slider affects the image appearance.

 3. Describe what happens to the appearance of the image when you 
move each of the four sliders in the B&C window.

You should have noticed that changing the brightness and contrast 
changes the appearance of different features in the image. Changing the 
appearance of an image to make features easier to see is called image 
enhancement. Another simple way to enhance images is to change the 
colors used to display the pixel values.

 Choose Image > Lookup Tables > Spectrum, and observe the details 
now visible in the image. (Feel free to “try on” some of the other 
color tables.)

 Close X-ray.tif and the X-ray.tif and the X-ray.tif B&C window.

Pixelated Pictures
Understanding Digital Images

Gray is a color too!
Most people don’t think of black, 
white, and gray as colors, but we’ll 
call them colors and we encourage 
you to do it too!

File > Open

Enhancing science
Image enhancement is a powerful 
tool. For example, being able to 
better see the details of a person’s 
heart and vessels can help a doctor 
to make a more accurate diagnosis.

File > Close

Student
Guide
Student
Guide
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Big pictures from little squares      
 Open Stadium Picture.tif. This image is really three images, Stadium Picture.tif. This image is really three images, Stadium Picture.tif

each in a separate layer, or slice.

 Press the > and < keys to move through the slices of Stadium 
Picture.tif. Or use the arrows on the slider bar at the base of the Picture.tif. Or use the arrows on the slider bar at the base of the Picture.tif
image.

Have you ever seen fans in a stadium form a big picture as part of a 
halftime show? Each seat in the “card section” is assigned one or more 
large cards, each a solid color. On command, each fan holds up the 
appropriate card. Viewed from across the fi eld or from high above the 
stadium, the individual cards blend together to form a large picture.

Close up, all you can see are the individual colored cards. The pixels in a 
digital image are similar to the cards held by each fan.

 4. How would the stadium picture look if the fans ran dom ly traded cards 
with each other?

The location of each colored card is extremely important for displaying the 
picture. Stadium sections have “addresses” for every seat—locations are 
given by seat and row numbers. Digital images have a similar system for 
describing the location of each pixel.

 Close Stadium Picture.tif.Stadium Picture.tif.Stadium Picture.tif

Discovering pixel “addresses”
 Open Mona Lisa.tif.Mona Lisa.tif.Mona Lisa.tif

 Click , then click the image several times until you can see , then click the image several times until you can see 
individual pixels.

 Move your cursor hor i zon tal ly across a row of pixels, and watch 
the changes in the status bar.

 5. Which number in the status bar changes one unit for every one pixel 
you move in the horizontal direction?

 Move the cursor ver ti cal ly (up or down) in a column of pixels, and 
again watch the changes in the status bar.

 6. Which item in the status bar shows a pixel’s vertical location?

 7. Describe how seat and row numbers in a stadium compare to the 
co or di nate system used to locate specifi c pixels in a digital image.

 8. How is the X,Y coordinate system in this digital image similar to 
math e mat i cal graphs you have used?

 Double-click  to view the entire image again.  to view the entire image again. 

 Based on what you observed, move your cursor to the origin of 
the image (the pixel with the lowest X,Y coordinates).

 9. Where is the origin (row 0, seat 0) of the image?

 10. How could you fi nd out the total number of pixels in this image?

 11. How many pixels are in this image?

Image width and height
Remember that in ImageJ, the “row” 
and “seat” numbers start with 0,0 
not 1,1. That means that you have 
to add 1 to the maximum X and Y 
coordinates to get the width and 
height of the image.

Mona Lisa’s pixel 
locations 
The Mona Lisa image is moderately 
large and is not displayed at full size 
by ImageJ. As a result, pixel locations 
will not change uniformly as you 
move the cursor over the image. 

To display it at full size, select Edit 
> Options > Image . . . and click 
Open Images at 100%. Then 
reopen Mona Lisa.tif.  

Make sure you reset this option 
when you have fi nished this part of 
the lesson (click Open Images at 
100%). 
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The value of a pixel
Besides the specifi c address given by X and Y coordinates, each pixel in a 
digital image has another number associated with it.

 Use the  tool to zoom in several times until you can see  tool to zoom in several times until you can see 
individual pixels.

 Place your cursor on the lightest pixel in your fi eld of view and 
read its Value in the status bar. Do the same for the darkest pixel 
you see.

 12. What are the highest and lowest pixel values you can fi nd in this image?

Assigning colors to values
In a stadium picture, each fan is given a card with a specifi c color.  
Likewise, in a digital image each pixel value is represented by a specifi c 
color. In digital images, a color is assigned to every pixel value using a 
lookup table. A simple lookup table for an image with up to 16 different 
values is shown at the right.

ImageJ uses 8-bit lookup tables containing 28, or 256, different colors. 
Normally, pixels with a value of 0 are shown as white and pixels with a 
value of 255 are shown as black. (If that seems backward to you, ImageJ 
can also be set to assign 0 to black and 255 to white—both ways are 
“correct.”) Two hundred fi fty-four colors or shades of gray are used to show 
the values be tween white and black.

 13. Zoom in on any pixel in your image. Write down its location and value.

 Choose Image > Lookup Tables, and pick a new lookup table from 
the available choices. The new lookup table assigns new colors to 
each pixel value.

 Move your cursor back to your test pixel from question 13.

 14. Has the pixel value changed?

 Try other lookup tables, and check the value of your test pixel.

 15. What happens to the pixel values when you apply a new lookup table 
to an image?

 16. Describe how the lookup table affects the appearance of a digital image.

 Change the lookup table back to grayscale when you are fi nished 
by choosing File > Revert.

Bit depth
The number of possible pixel values in an image is often called the bit depth
of the image. Bit depth is determined by the number of binary digits, or 
bits, that are used to represent the value of each pixel. ImageJ can work 
with 8-, 16-, and 32-bit images. The table below shows the number of 
different values that are possible at each bit depth.

Bit Depth Possible Pixel Values
8-bit 28 = 2568 = 2568

16-bit 216 = 65,53616 = 65,53616

32-bit 232 = 4,294,967,29632 = 4,294,967,29632

15
14
13
12
11
10

9
8
7
6
5
4
3
2
1
0

A 4-bit lookup table
A 4-bit lookup table has 24 or 16 
diff erent colors or shades of gray.
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More practice
If you want to practice working with 
more 16- and 32-bit images, you will 
fi nd them in the 16-bit Images and 
32-bit Images folders.

Mona a la mode
Another name for the most 
frequently used value is the Mode.

32-bit fl oating point
The 32-bit image format used by 
ImageJ represents values using 
32-bit fl oating point notation. This 
allows pixels to represent values 
containing a decimal point.  It 
is especially useful for scientifi c 
imaging, because each pixel value 
can be an actual measurement 
value, such as 31.625 W/m2. (The 
units, of course, are not stored with 
the pixel value.) These “32-bit fl oat” 
values can represent numbers 
ranging from about 1.7 x 1038 to 
5.9 x 10-39. The possibilities are nearly 
endless!

0 255

Sorting the cards

Wow! A pixel in a 32-bit image can represent any one of more than 4 billion 
possible values! Unfortunately, ImageJ uses lookup tables with only 256 
colors. When displaying 16- and 32-bit images, ImageJ divides the range of 
possible pixel values into 256 groups, called bins, and assigns a single color 
to all of the pixels in each bin. That means that in a 16-bit image, a single 
color can represent a range of up to 256 different pixel values, and in 32-bit 
images, each color of the lookup table can represent nearly 16.8 million 
different values! The trick to working with 16- and 32-bit images is learning 
how to assign the 256 available colors to the range of pixel values you’re 
most interested in. This process is called windowing.

 Open the Galaxy.tif image. (Do not close Galaxy.tif image. (Do not close Galaxy.tif Mona Lisa.tif.)Mona Lisa.tif.)Mona Lisa.tif

This is a 16-bit image of the Andromeda Galaxy taken with a digital 
camera mounted on a telescope on Kitt Peak in Arizona. The image doesn’t 
contain a full 65,000 different pixel values, but it does use far more than 256 
different values to record faint details of the galaxy. At fi rst, it doesn’t look 
like much, but looks can be deceiving.

   Choose Image > Lookup Tables > Fire.

Our eyes are more sensitive to different colors, so you should see a little 
more detail in the image using the Fire lookup table.

   Choose Image > Adjust > Window/Level.

The Window/Level (W&L) panel contains two sliders. One controls the 
window width—the range of pixel values in the image that the lookup table 
is applied to. Pixel values above this range are displayed as black, and 
values below it are displayed as white. The other slider controls the Level—
the pixel value where the window (and the lookup table) is centered. These 
adjustments will make more sense after you experiment with them a bit.

 Adjust the Window and Level controls in the W&L panel until 
you think the maximum detail is visible in the image.

 17. What Window and Level settings produce the best range of detail in 
the image?

 Close the Galaxy.tif image and the Galaxy.tif image and the Galaxy.tif W&L window.

Back to the stadium
Imagine that you want to create the Mona Lisa as a stadium picture. To 
produce the individual cards to give to the fans, you will need to know how 
many cards of each shade to paint.

 Choose Analyze > Histogram to see a histogram of the pixels used 
to create Mona Lisa.

Think of a histogram as a way of organizing your stadium cards. If you sort 
them by pixel value along a number line from 0 to 255, the resulting piles 
of cards would resemble a histogram. The most-used colors (values) would 
have the highest piles while the least-used colors would have smaller piles. 
The piles show the amount (the number of cards) of each color (value) 
needed to produce the picture.

 18. What is the most frequently used pixel value (color) in Mona Lisa?

 Close the Histogram window.
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MRI = NMR
Magnetic resonance imaging is 
sometimes called nuclear magnetic 
resonance imaging (NMR) because 
it measures the response of atomic 
nuclei to strong magnetic fi elds.

Essentially, MRI maps the locations 
of diff erent kinds of atoms along a 
plane or slice of an object, usually 
some part of a person’s body.

Thresholding
The Threshold dialog box lets 
you choose from three diff erent 
methods of highlighting a range of 
pixel values.

Highlighting pixels in the image
Sometimes it is useful to identify the pixels in an image whose values are 
within a certain range. For example, let’s pretend for a moment that the 
pixel values in Mona Lisa represent temperature instead of brightness. As 
part of a diagnostic procedure or research study, you might want to know 
which parts of the image are between 30oC and 45oC.

If the back of each “card” used to create the image was colored bright red, 
you could highlight where specifi c pixel values occur in the image. Imagine 
fl ashing this message on the scoreboard while the card section is showing 
the Mona Lisa image:

You can do something similar in ImageJ. It is a process called Thresholding.

 Choose Image > Adjust > Threshold to turn on Thresholding mode.

In Thresholding mode, the pixels whose values are within a range of values 
are highlighted.

 Highlight all of the pixels with values be tween 30 and 45 by 
adjusting the Threshold range using the two slider controls in the 
Threshold panel.

 You can also set the upper and lower Threshold limits precisely by 
clicking the Set button and entering exact values. Use this method 
to set the Threshold range to 49–73.

 With Thresholding on, create a new histogram to see which pixels 
are within the Threshold limits.

You can highlight a single pixel value by setting the upper and lower limits 
of the Threshold to the same value.

 Set the Threshold to highlight pixels with a value of 227 in the 
Mona Lisa image.

 19. Where in the image are most of the pixels with a value of 227 located?

 Close Mona Lisa.tif and the Mona Lisa.tif and the Mona Lisa.tif Threshold window.

Careers using digital images
Many careers use digital images. Government and public agencies as well 
as private businesses use digital images to display, interpret, and archive 
in for ma tion. For example, space agencies, weather bureaus, and hospitals 
make digital images or scan images and doc u ments for storage onto CD-
ROMs and other media. Today, image processing is used in a variety of fi elds 
ranging from graphic arts to medical tech nol o gy to city planning. In this 
section, you will explore a few workplace applications of digital imaging.

 Open Medical Image.tif.Medical Image.tif.Medical Image.tif

This is a mag net ic res o nance image (MRI) of a patient’s head. In the fi eld 
of medicine, image processing techniques can allow a doctor to visualize 
anatomy without surgery. Health-care technicians use a wide variety of 
spe cial ized equip ment for collecting images like this.
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Filtering noise, Part II
Another way to fi lter noise is to 
choose Process > Filters >
Median.  Try this method on 
another part of the Mercury image, 
and compare the results to the fi rst 
method you used. Experiment with 
the Median fi lter’s radius setting to 
fi nd the radius that gives the best 
results. 

Sinuses?
The sinuses are the large, air-fi lled 
cavities between the forehead, eyes, 
nose, and the brain. The air outside 
the patient is black, so black areas 
inside the head are likely fi lled with 
air.

On your own
 • Look at a newspaper photo with 

a magnifying glass. Describe 
how the picture is similar to and 
diff erent from a digital image.

 • Design and create your own 
stadium picture. Use a piece 
of graph paper to create your 
design.

 • Visit some one in a career that 
uses digital images. Describe 
how they use digital images in 
their job.

Since an MRI is in a digital format, tech ni cians can easily isolate and select 
specifi c struc tures and types of tissue for further analysis. In this image, the 
dark areas behind the eyes and nose are the sinus cavities. A doctor may 
want to study these to identify or diagnose breathing disorders.    

 Turn on Thresholding, and adjust the range to highlight the 
sinuses.

 Close Medical Image.tif and the Medical Image.tif and the Medical Image.tif Threshold window.

When an image is in a digital format, technicians can easily isolate and 
enhance particular portions of the image, whether it’s the image of a heart 
or the surface of another planet.

 Open Mercury Surface.tif.Mercury Surface.tif.Mercury Surface.tif

In 1974-75, the Mariner 10 spacecraft made three passes by the planet 
Mer cu ry. This image of Mercury’s surface is one of the photos taken by 
Mariner 10. In ter fer ence from radio waves and the sun produced static, or 
noise, that gives the image a salt-and-pepper appearance. Noise like this 
can be removed by pro cess ing the image with a digital fi lter that identifi es 
and replaces the noisy pixels with new, more realistic values. Planetary 
geologists and as tron o mers fre quent ly use such fi l ter ing tech niques to 
en able them to more clearly see features they might not otherwise notice or 
be able to detect.

 Use the Rectangular selection tool  to select part of the image. to select part of the image.

 Choose Process > Noise > Despeckle to pro cess the image.

 20. What happened to the part of the image inside the area you selected?

 Close Mercury Surface.tif.    Mercury Surface.tif.    Mercury Surface.tif

 Open Math Image.tif.Math Image.tif.Math Image.tif

Any grid of num bers can be displayed as a digital image. This image was 
created using a spreadsheet program and shows the equations xy = 1 and 
xy = -1. Some math e mat i cal functions show intricate and attractive patterns 
when displayed as digital images. Artists, scientists, and engineers create 
interesting and beautiful images using math e mat i cal func tions to generate 
pixel values. The colors in the image depend on the lookup table used.

 Apply various lookup tables to the image, and observe how its 
appearance changes.    

 Close Math Image.tif.Math Image.tif.Math Image.tif

 Open Painting.tif.Painting.tif.Painting.tif

This image is a drawing created by artist Patti Parsons. She selectively 
changed pixel values from white to a new color using the selection tools 
as drawing tools. Patti uses the computer as a sketchbook to try out 
different color combinations before painting her works on canvas. Graphic 
artists rely heavily on digital imagery to create print and electronic art, 
ad ver tise ments, and video special effects.

 Close Painting.tif.Painting.tif.Painting.tif
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Data
Sheet

Pixelated Pictures

Name(s)   ______________________________ Class  _________   Date  __________________

 1. What do you see?

 2. What do you notice about the status bar? (Be specifi c!)

 3. Describe what happens to the image when you move each of the four sliders in the B&C Window.

 a. Minimum

 b. Maximum

 c. Brightness

 d. Contrast

 4. How would the stadium picture look if the fans ran dom ly traded cards with each other?

 5. Which number in the status bar changes one unit for every one pixel you move in the horizontal 
direction?

 6. Which item in the status bar shows a pixel’s vertical location?

 7. Describe how seat and row numbers in a stadium compare to the co or di nate system used to locate 
specifi c pixels in a digital image.

 8. How is the X,Y coordinate system in this digital image similar to math e mat i cal graphs you have used?

 9. Where is the origin (row 0, seat 0) of the digital image?
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 10. How could you fi nd out the total number of pixels in this image?

 11. How many pixels are in this image?

 12. What are the highest and lowest pixel values you can fi nd in this image?

 a. highest = _____

 b. lowest = _____

 13. Zoom in on any pixel in your image. Write down its location and value.

 a. location:  X = _____, Y = _____

 b. value = _____

 14. Has the pixel value changed?

 15. What happens to the pixel values when you apply a new lookup table to an image?

 16. Describe how the lookup table affects the appearance of a digital image.

 17. What Window and Level settings produce the best range of detail in the image?

 a. Window = _____

 b. Level = _____

 18. What is the most frequently used pixel value (color) in Mona Lisa?

 19. Where in the image are most of the pixels with a value of 227 located?

 20. What happened to the part of the image inside the area you selected?


