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Lights, Camera, Action!
Creating and using image stacks

Lesson

Have you ever wanted to make a movie? Well, here’s your chance! With 
your imagination and a little help from image processing technology you 
can easily create digital animations using stacks of images. You can even 
save them as QuickTime® and AVI movies for use with other applications.

At the movies
First, let’s observe a ready-made animation.

 Open Galloping Horse.tif.Galloping Horse.tif.Galloping Horse.tif

 Drag the scroll bar at the bottom of the stack window left and 
right to see the frames, or slices, of the stack.

This series of images was created in 1878 by Eadward Muybridge, an early 
pioneer in the use of photography to study animal locomotion.

 Press the backslash (\) key while holding down Control (Win) or 
Command (Macs) to start the animation. Click on the image to 
stop the animation, or use the \ key alone.\ key alone.\

 Experiment with changing the speed of the animation. To change 
the speed, choose Image > Stacks > Animation Options….

 1. What are the fastest and slowest animation speeds in frames per 
second?

What is a stack?
A set of images displayed within a single window is called a stack. A stack 
is similar to a pad of paper or a deck of cards, except that each “card” is a 
digital image. These images can show many things—a sequence of events, 
parts of a larger image, or slices through an object at different depths. In 
fact, ImageJ refers to the individual, “still” images within the stack as slices.

This lesson will focus on the use of stacks for animating a series of images. 
Perhaps you have created a simple fl ip-book animation using a stack of 
paper. When the images are shown quickly, the eye “sees” motion. This is 
the basic principle that is used for making movies. Films and videos are 
really just series of still pictures shown in a rapid sequence. By arranging a 
series of images in a stack and fl ipping through them, you can create your 
own animation.

 Use the > and < keys or the scroll bar to move forward and 
backward through the stack as you view the individual slices.

 Below the title bar of the Galloping Horse.tif window is a row of Galloping Horse.tif window is a row of Galloping Horse.tif
numbers. The fi rst number refers to the slice of the stack that you 
are currently viewing, and the second number refers to the total 
number of slices in the stack.

 2. How many slices are there in Galloping Horse.tif?Galloping Horse.tif?Galloping Horse.tif

File > Open…

Stack Window

Slice
Counter

Scroll BarScroll Bar

Dimensions

Memory Size
Bit Depth

Image > Stacks >
Animation Options…
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 The other numbers below the title bar refer to the image’s 
dimensions (width × height), bit depth (number of possible 
colors), and size (amount of computer memory the stack occupies). 
The size of each open image is also listed next to the image name 
in the bottom section of the Window menu.

 3. How large (in kilobytes, kb) is Galloping Horse.tif?Galloping Horse.tif?Galloping Horse.tif

Unstacking and restacking
The slices of a stack can be separated into individual windows using the 
Image > Stacks > Convert Stack to Images command. The images can be 
reassembled into a stack using the Image > Stacks > Convert Images to 
Stack command.

 Practice unstacking and restacking Galloping Horse.tif.Galloping Horse.tif.Galloping Horse.tif

 4. Look at the bottom of the Window menu when Galloping Horse.tif
is unstacked. How is it different from when the images are in a stack?

 5. How do the sizes of the individual images compare to the size of the 
stack?

 If necessary, reassemble the galloping horse images into a stack.

Editing a stack
 To draw on an image, select a line or region by using one of the 

selection tools ( , , , , , , , , , , , or , or  ). Hold down the  ). Hold down the F key 
(for “Fill”) while you drag the selection around on the image to use 
the selection as a paintbrush. Use this drawing technique to make 
changes to the images in the stack.

 Try inserting and deleting individual slices in the stack using 
Image > Stacks > Add Slice and Delete Slice. Experiment with 
holding down the Alt (Win) or Alt (Win) or Alt Control (Mac) key while inserting 
slices and notice where the slice is added.

 6. When you add a slice with the Alt or Alt or Alt Control key pressed, is the slice 
added before or after the current slice?

 Close Galloping Horse.tif.Galloping Horse.tif.Galloping Horse.tif

Make your own movie
Try creating your own animation.

 Choose File > New to create a new blank stack named My Movie. 
To make a convincing animation, you will probably need at least 
12 slices.

 On the fi rst slice, draw a simple scene. Be sure to include an object 
that you want to move in the animation.

 Use the > key to advance to the next slice, and draw the next frame 
of your animation. Use the scroll bar at the bottom of the stack 
window to move through the stack and test your animation. (See 
Drawing hints on the next page.)

Creating a new 
blank stack

Can’t see the image 
size?
If you can’t see the size of the image  
in the window, try stretching the 
window out a bit. 
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 Here are the basic techniques you will use:

To do this… …follow these procedures

Make a selection Use  , , , , , , , or , or   to select a region of interest.  to select a region of interest.

Copy a selection Choose Edit > Copy.

Paste a selection Choose Edit > Paste.

Draw or paint
on the image

Make a selection using any of the selection tools. Press 
the D key to draw an outline, F to fi ll the shape, or 
hold down F while dragging the selection to use the 
selection shape as a “paintbrush.”

Add text Use  to enter text, then choose  to enter text, then choose Edit > Draw.

Change the text 
or drawing color

Double-click  , and choose a new color from the  , and choose a new color from the 
palette.

 When you are fi nished with your animation, press \ (Control\  for 
Windows and Command \ for older Macs) to start the animation. Command \ for older Macs) to start the animation. Command \
If your movie runs too slow or too fast, choose Image > Stacks >
Animation Options to change the speed. (Movies and television 
both animate at a rate of around 30 frames per second.)

A stack is great for looking at a series of images one after the other. 
However, if you want to include the stacked images in a printed report, you 
need a different way to display them. A montage allows you to see all of a 
stack’s slices in a single image.

 Choose Image > Stacks > Make Montage to create a montage 
of your stacked animation. Experiment with the set tings in the 
montage dialog box until you are pleased with the results.

 If possible, print your montage.

 Save the montage and/or the stack if you like. Choose the AVI 
format to save your stack as a movie fi le that will play on most 
computers.

 Close all open images.

“Seeing” with animation
In addition to its use in the fi lm industry, digital animation is a valuable 
technique widely used in other fi elds. Processes that occur too quickly 
or too slowly for the eye to perceive can be “seen” using animation. 
Images captured over an extended period of time can be sped up to 
show changes taking place that might not otherwise be noticeable. For 
example, me te o rol o gists use an i ma tion to follow the move ment of clouds, 
hurricanes, and weather fronts.

Choose File > Import > Image Sequence. Navigate to the 
Hurricane Andrew folder, and open it. In the Open Image 
Sequence dialog box, select the fi rst fi le, named About Andrew 
WV.tif, and click Open.

 In the Sequence Options dialog box, accept the default settings, 
and click OK.

 7. Describe what happens.

 Close all open image windows and the Log window.

Drawing hints
You can either draw each frame 
of your animation from scratch, or 
modify a copy of the previous slice. 
To duplicate a slice:

 • Choose Edit > Selection > 
Select All.

 • Choose Edit > Copy.

 • Use the slider at the bottom of 
the stack window to advance 
to the next slice.

 • Choose Edit > Paste.
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You have just learned an important rule for stacking a set of images—all of 
the images must be the same size (width and height) in order to stack them.

 Choose File > Import > Image Sequence... again, and open 
Hurricane Andrew. This time, in the Sequence Options dialog 
box, enter 2 for the starting image. ImageJ will now skip over 
the fi rst image (the one that’s a different size than the others) and 
should create a stack from the remaining images in the folder.

In 1992, Hurricane Andrew swept through the Caribbean, Florida, 
and Louisiana in 72 hours. Using animation to track the movement of 
hurricanes like Andrew can help provide early warnings for people seeking 
safety during dangerous storms.

 Animate the hurricane stack.

 8. What measurements would you need to make to be able to calculate 
the speed of the hurricane?

 Close the hurricane stack.

In a similar manner, animation can be used to slow down events that 
happen too fast for us to see. Sports trainers often use an i ma tion to analyze 
motion such as the swing of a golfer or tennis player. Physicists study the 
paths of moving objects and the forces that cause them to move using 
animation. Bio me chan i cal en gi neers some times use an i ma tion to help them 
determine the points of greatest wear when designing running shoes.

 Import the sequence of images in the Lightning folder.

 Animate the images.

Carefully observe these images of lightning taken during a typical Arizona 
summer thunderstorm. This event lasted less than two seconds.

 Use the animation slider or set the animation speed to move slowly 
through the stack and observe the behavior of the lightning.

 9. Write down  another phenomenon that occurs too quickly to “see” 
with our eyes. Describe how imaging could be used to slow down the 
event so that it can be analyzed.

 Close the Lightning stack.

Animation makes it easier to observe, interpret, and predict patterns.

Using stacks to show three dimensions
In the fi eld of medicine, animation is often combined with other imaging 
techniques to provide noninvasive methods for visualizing anat o my.

 Import the sequence of Brain images in the Makes My Head 
Spin folder.

Magnetic Resonance Imaging (MRI) is a powerful way to examine the 
struc ture of a human body without cutting it open. This tool is es pe cial ly 
useful when ex am in ing delicate structures like the human brain. An MRI is 
made by placing a patient in a strong magnetic fi eld, exposing him or her to 
radio waves, and then recording and analyzing the way the patient’s atoms 
respond. Unlike x-rays, which reveal bone and other hard tissue, MRI excels 
at creating images of soft tissue. For example, a brain tumor that cannot be 
detected with an x-ray might be easily identifi ed in an MRI.

Wrong image
sequence?
When importing an image 
sequence, the images are added 
to the stack in alphabetical (or 
numerical) order.

If the images are not named in the 
order that they are to be animated, 
you will have to open them one 
at a time in the correct sequence, 
then choose Image > Stacks 
> Convert Images to Stack to 
create the animation stack.

Remember to close any windows 
that are not part of the animation 
before building the stack.

File > Import >
Image Sequence…

File > Import >
Image Sequence…

File > Import >
Image Sequence…
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Another advantage of MRI technology is that its images represent very thin 
slices through the subject, making the exact size and location of features 
easy to determine. The 27 images in the Makes My Head Spin stack show 
cross-sections of a human head (with no tumors, fortunately!). Images were 
made every 5 mm, starting from the middle of the nose and continuing up 
through the eyes.

Animating the brain
 Animate the Brain stack.

When you animate the stack, you take a trip through the brain from the nose 
to the top of the head. Although each individual slice has only two di men sions, 
the stack of slices gives us a three dimensional view.

Reslicing the brain
ImageJ can use data from the individual slices in a stack to create new 
views of an object. Imagine cutting straight down through the brain stack 
and looking at the cut from the side. This is called reslicing.

Use  to make a straight line selection across the brain image in  to make a straight line selection across the brain image in 
any direction.

 Choose Image > Stacks > Reslice. Set the Input Z Spacing to 5,
and click OK. (For comparison, try setting the spacing to 3.)

 Reslice the stack along other straight line selections drawn at 
various angles, and experiment with the options in the Reslice
dialog box.

 10. What structures can you see within the brain? Use the diagram at right 
or a textbook to help you identify and describe a few of them.

Projecting the brain
Imagine that each slice of the brain stack was printed on a sheet of clear 
plastic and you held the stack of plastic sheets in your hand. By tilting and 
rotating the stack of images, you could view them from different angles. 
ImageJ can create a series of images that show how a stack would appear as 
it is rotated around any of three axes.

 Close all of the resliced images, but leave the brain stack open.

 Choose Edit > Selection > Select None to make sure there are no 
selections on the brain stack.

 Choose Image > Stacks > 3D Project to project the stack. Fill in the 
3D Projection dialog box as shown at right. Don’t worry for now 
what all of these settings mean. They were chosen to allow you 
to look “through” the hard bone tissue of the skull at the softer, 
fainter brain tissue. Click OK.

 To increase the contrast of the images, choose Image > Adjust >
Brightness/Contrast, and click the Auto button.

 Click the Apply button, then click Apply button, then click Apply Yes when asked if you want to 
adjust the contrast of all of the slices in the stack.

 Close the B&C window.

 Animate the completed projection stack.

Major structures
of the brain

Cerebral CortexCerebral Cortex

MedullaMedulla

CerebellumCerebellum

MidbrainMidbrainMidbrain

Corpus

CallosumCallosum

ThalamusThalamus PonsPons

Spinal CordSpinal Cord

Upside-down?
Your resliced brain image will be 
upside-down with this procedure. To 
make it right-side up, check the Flip 
Vertically box. 
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On your own
Use the images in the On Your Own folder to try out the following 
techniques and to explore stacks and animation techniques.

Making a stack from a montage
Earlier in this lesson you turned a stack into a single image called a montage. 
You can also go the other direction, turning a montage into a stack.

 Close all open images, and open 1 Running Horse.tif.1 Running Horse.tif.1 Running Horse.tif

 Click  , and select the fi rst frame of the running horse. , and select the fi rst frame of the running horse.

 Choose Image > Duplicate to duplicate the selection into its own 
window. Click OK. Drag the new window out of the way.

 Choose 1 Running Horse.tif from the 1 Running Horse.tif from the 1 Running Horse.tif Windows menu to 
activate the source image again.

 Drag the selection outline you made to the second running horse 
frame.

 Duplicate this selection. Repeat this process until you have made a 
sep a rate image from each of the nine running horse frames.

 Close the Running Horse montage image.

 Stack and animate the running horse frames. Close the stack.

Registering slices in a stack
The Rocket Stack shows a model rocket being launched. Unfortunately, 
the camera moved, making it diffi cult to analyze the motion of the rocket. 
Philippe Thevenaz, a researcher of the Biomedical Imaging Group of the 
Swiss Federal Institute of Technology, created an amazing ImageJ add-on 
that automates the process of registering the images in a stack.

 Open the 2 Rocket Stack.tif image.

 Choose Image > Duplicate to make a copy of the fi rst slice of the 
stack (not the whole stack, though it will still work if you do.)

 Choose Plugins > TurboReg > TurboReg.

 Use the default settings, and select the Accurate option.

 Click the Batch button.

The plugin takes over and registers the stack!

 Animate the registered rocket stack. To compare the stacks before 
and after the registration process, you can click on one of the 
original rocket stack copies and animate it.

Batch button.

Image registration —correcting for 
diff erences in position of features in 
two or more images due to camera 
motion and other eff ects.

Note to Mac OS 9 users —
TurboReg is only available for 
Windows and Mac OSX.
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Data
Sheet

Lights, Camera, Action!
 1. What are the fastest and slowest animation speeds in frames per 

second?

 a. fastest = ______ fps (frames per second)

 b. slowest = ______ fps (frames per second)

 2. How many slices are there in Galloping Horse.tif?Galloping Horse.tif?Galloping Horse.tif

 3. How large (in kilobytes, kb) is Galloping Horse.tif?Galloping Horse.tif?Galloping Horse.tif

 4. Look at the bottom of the Window menu when Galloping Horse is 
unstacked. How is it different from when the images are in a stack?

 5. How do the sizes of the individual images compare to the size of the 
stack?

 6. When you add a slice with the Alt or Alt or Alt Control key pressed, is the slice 
added or before or after the current slice?

 7. Describe what happens.

 8. What measurements would you need to make to be able to calculate 
the speed of the hurricane?

 9. What do you notice about the path the electricity travels?

 10. What structures can you see within the brain? Use a textbook to help 
you identify and describe a few of them.

Name(s)   ______________________________ Class  _________   Date  __________________


