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More Than Numbers
Graphing digital images

Lesson

Part 1: “See” the numbers
As you look at an image, your eyes give your brain clues about the shape, 
en vi ron ment, and meaning of objects in the image. However, some of the 
data contained within an image may be diffi cult for your eyes to detect 
or interpret effectively. Graphing image data can help you obtain useful 
in for ma tion you might not otherwise be able to see. In this lesson, you will 
create and interpret graphs of the numbers that make up digital images.

 Open 1 Colorado DEM.tif.1 Colorado DEM.tif.1 Colorado DEM.tif

Many digital images are like photographs; the pixel values in the image 
are directly related to the brightness in the original scene. In some images, 
however, the pixel values represent mea sure ments other than bright ness.

 Choose Analyze > Set Measurements…, and set the number of 
decimal places to zero. This will simplify things by displaying all 
measurements as whole numbers.

 1. Look carefully at this image. Then, describe what you see.

 2. What do you think this image shows?

 Move your cursor across the image, and read the pixel values in 
the status bar of the ImageJ window.

 3. What do you think the pixel values in the image represent?

This image, called a Digital Elevation Model, or DEM, displays a regular 
grid of elevation mea sure ments for a section of Earth’s surface. It is a type 
of digital map that is similar to a topographic map since it allows you to 
read elevation data. The data from a DEM can be used to create maps that 
show the locations of animal communities, soils, and vegetation types. This 
particular DEM image shows the state of Colorado.

 Move your cursor around the image again as you observe the 
values in the status bar.

This DEM is an 8-bit image with possible pixel values ranging from 0 
to 255. These values are converted to elevation using an equation that 
was saved with the image. In the status bar, the calibrated pixel value is 
followed by the raw, uncalibrated pixel value in parentheses.

 4. What are the highest and lowest elevations you can fi nd? What raw 
pixel values correspond to each elevation?

Rather than simply examining this image with your eyes, you can create 
a graph to help you “see” the numbers—in this case, the elevation data of 
the image. A his to gram is a graph that shows the frequency distribution of 
values in the image—in other words, it shows the number of pixels there 
are for each different value in the image.

 Choose Analyze > Histogram… to create a histogram for the image.

The status bar
The status bar is located below the 
tool bar in the ImageJ window.ImageJ window.ImageJtool bar in the ImageJ window.ImageJ window.ImageJ

Status BarStatus BarStatus Bar

File > Open

Analyze > Histogram

Calibrated and
uncalibrated images
In uncalibrated (raw) images, the 
pixel values are proportional to 
some measurement but are not 
measurement values themselves. 
They have meaning relative to the 
other pixel values in that image 
but don’t tell you what the actual 
measurement was at each point in 
the image.

In calibrated images, the pixel values 
are converted to approximate 
measurements using an equation. 
For this image, the calibration 
equation is:

elevation = 45.6 x raw value +3,304.4

(To see the calibration equation, 
choose Image > Show Info…)
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 Move your cursor across the histogram plot, and read the Value
(calibrated pixel value, or elevation) and Count (number of pixels) Count (number of pixels) Count
in the bottom part of the histogram win dow.

 5. How many pixels in the image represent an elevation of 8,002 feet?

 6. According to the histogram, what are the highest and lowest 
elevations in the image? (Reported as Max and Max and Max Min in the Histogram
window.)

 7. What elevation occurs most often in this DEM? (Reported as the Mode
in the histogram window.)

 8. What is the average (Mean) elevation in the DEM?

Sometimes, it is useful to produce a detailed list of the information in the 
histogram.

 Click the List button in the Histogram window. Scroll down 
the histogram list, and examine the numbers. Double-check your 
answer to Question 5.

The histogram list shows the raw pixel values (level), the calibrated pixel 
value (value), and the frequency (count). This list can be saved or copied and 
pasted into a spreadsheet for further analysis.

 Close the Histogram and List windows.List windows.List

Profi le plots
 Move your cursor around the image to explore elevation patterns.

 9. Where are the areas of highest elevation located?

Another type of graph called a profi le can help you interpret image data.

 Use the Straight Line Selection tool   to select a line across the   to select a line across the 
image.

 Choose Analyze > Plot Profi le. (In the future, simply press K on 
your keyboard to create a profi le plot.)

The Plot Profi le function creates a graph of the pixel values along the 
selected line, or transect. The y-axis of the profi le shows the elevation, and 
the x-axis shows the distance along the transect. The scale of the y-axis 
ranges from the lowest to the highest value encountered along the transect.

 10. What are the lowest and highest elevations along the transect?

 Use  again to select another transect across the image, then  again to select another transect across the image, then 
create a new profi le plot.

The Y-axis scale is not the same for these two plots, making them diffi cult 
to compare. To compare data from several graphs, it helps to have a fi xed 
scale for the y-axis.

 Close both of the profi le plot windows.

 Choose Edit > Options > Profi le Plot Options, and use the highest 
and lowest elevations of the image (from Question 6) to set the 
Minimum Y and Minimum Y and Minimum Y Maximum Y values.Maximum Y values.Maximum Y

 Create another profi le plot along the same transect.

 11. How does this profi le plot compare to the previous one you created?

Uncalibrated image 
histograms
When you create a list for an 
uncalibrated image histogram, 
only the raw pixel value (value) and 
frequency are reported.

Keeping it horizontal
To force a line selection to be 
horizontal or vertical, hold down 
the Shift key while making the 
selection.

Histogram shortcut
Press the H key on your keyboard 
to make a histogram of the current 
image.

Colorado Landsat
This lesson includes an image 
named 2 Colorado Landsat that 
shows a satellite view of Colorado at 
the same scale as the DEM image. 
Feel free to open this image at any 
time and compare it to the DEM.
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 Make several horizontal profi le plots across sections of the image.

 12. What kinds of landforms does this image show?

 Close all the profi le plot windows.

 Choose Edit > Options > Profi le Plot Options…, and turn off the 
Fixed Y-axis Scale option.

 To cancel any line selections, choose Edit > Selection > Select None.

Surface plots
It is diffi cult to visually translate shades of gray into elevation, so you will 
apply a lookup table that is used to represent elevation on relief maps.

 Choose File > Open…, and open the Elevation.lut color table.Elevation.lut color table.Elevation.lut

This helps, but to get a more meaningful view of the shape of the land, 
you will create a surface plot. Imagine drawing a profi le plot for every row 
of pixels in the image, stacking these plots next to one another, and then 
looking down on them at an angle. Essentially, that is what a surface plot is.

 13. Predict what a surface plot of this DEM will look like.

 Create a surface plot using the settings shown at right. (Choose 
Analyze > Surface Plot ... .)

 14. Describe the shape of the land. Where are the Rocky Mountains?

Your surface plot shows a view of the landscape from the southwest, 
looking to the northeast. By rotating the DEM to the right you can surface 
plot a view from the southeast, looking toward the northwest.

 Activate the 1 Colorado DEM.tif window and choose 1 Colorado DEM.tif window and choose 1 Colorado DEM.tif Image > 
Rotate > Rotate 90 Degrees Right to rotate the DEM clockwise a 
quarter-turn.

 Create another surface plot of the rotated image.

 15. Compare this surface plot from the southeast to the one from the 
southwest. What details are visible in this view that you could not see 
before?

 Experiment with different sizes and shapes of selections and 
different option settings for making surface plots.

 16. How does a surface plot created from a small area compare to one 
created from a larger selection?

 Close all the open image and plot windows.

Part 2: Interpreting digital data
 Open 3 Sea Surface Temperature.tif.3 Sea Surface Temperature.tif.3 Sea Surface Temperature.tif

In this image, pixel values represent the temperature, in degrees Celsius 
(°C), of the ocean’s surface. Black represents land, ice, or missing data. 
As you move your cursor around the image, you can read the changing 
temperature in the status bar. Note where the highest and lowest 
temperatures are located, as well as the value of the black areas.

 Choose Analyze > Set Measurements…, and set the number of 
decimal places to 1. This will allow you to read temperatures to 
the nearest 0.1°C.

Temperature calibration
The calibration equation for the sea 
surface temperature image is:

Temp (°C) = 0.15 x (raw px value) -3

Note: Checking the Note: Checking the One Polygon One Polygon 
Per Line option disables the 
Polygon Multiplier setting.

Surface plot optionsSurface plot options

Plots of plots (Warning!)
When you are creating profi le and 
surface plots, always remember to 
be sure the original image window 
is active before making the plot. 
Otherwise, you may accidentally 
make a plot of the previous plot 
window instead of the image!



90 Discovering Image Processing
©2006 The Center for Image Processing in Education and 

portions ©1998 Arizona Board of Regents.
Limited classroom reproduction rights are granted earlier in this work.

 Create a histogram of the image.

According to the statistics displayed in the histogram window, the mode 
(the most common value) is -3°C. Move your cursor over the image to see 
what areas this value corresponds to.

 17. What parts of the image have a calibrated value of -3°C? Do you think 
this value is the surface temperature in these areas?

In this case, you can’t use the mode value calculated automatically by 
ImageJ to fi nd the most commonly occurring sea surface temperature. 
Instead, move your cursor over the highest peak in the histogram, and read 
the temperature that corresponds to that peak.

 18. What sea surface temperature occurs most frequently in this image?

 Make several vertical (up and down) profi le plots across the ocean 
basins.

 19. What do these north-south profi le plots tell you about the relationship 
between latitude (distance north or south of the equator) and sea 
surface temperature?

 Close all the open image and plot windows.

 Open the 4 Tree Rings.tif image.4 Tree Rings.tif image.4 Tree Rings.tif

This image shows growth rings in a cross-section taken from a tree.

 Create a profi le plot along an interesting part of the cross-section. 
You may need to reset the Y values in the Profi le Plot Options.

 20. What do the peaks and dips on the plots represent?

 21. What do you think the different widths of peaks and dips show?

Tree ring scientists (dendrochronologists) use similar methods to es tab lish 
dates of wood sam ples and to understand how a tree’s growth is affected 
by its environment.

 Close all the open image and plot windows.

 Open the 5 Lambert Crater.tif image. This Apollo 15 image 5 Lambert Crater.tif image. This Apollo 15 image 5 Lambert Crater.tif
shows Lambert Crater, which is approximately 30 km (19 miles) 
wide and 2400 m (8,000 ft) deep.

 22. Before you make a profi le plot across the crater, sketch your prediction 
of what you think the profi le plot will look like.

 Make a profi le plot across the crater.

 23. Sketch the resulting plot, and compare it to your prediction.

Many people predict the shape of the plot incorrectly because they expect 
to see a plot of elevation. Remember that profi le plots are based on pixel 
values. If the pixel values represent elevation, then you will get an elevation 
plot. However, the pixel values in the Lambert Crater image represent the 
bright ness of the surface, including areas of shadow, so the profi le plot is a 
brightness—not brightness—not brightness— elevation—plot.

 Close all the open image and profi le plot windows.

 Open 6 Crater Lake.tif. The pixel values in this image represent 6 Crater Lake.tif. The pixel values in this image represent 6 Crater Lake.tif
el e va tion measurements of the area surrounding a famous lake in 
Oregon that sits in the crater of a dormant volcano.

Reading mode value of 
data from histogram
The Mode value given in the 
Histogram window represents No 
Data values in the image. To fi nd the 
modal value of the data, read the 
value of the peak of the histogram. 
(Hint: The peak value has the highest 
count.)

Ignore this!Ignore this!

Put cursor here

Read the ValueRead the Value
and Count here
Read the ValueRead the Value

and Count here
Read the ValueRead the ValueRead the Value

and Count here
Read the ValueRead the Value

Apollo 15
Apollo 15 was the fourth mission 
to land on and explore the moon. 
While two astronauts were exploring 
the surface, a third was orbiting 
the moon taking photographs and 
making other observations of lunar 
features.
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Window > Tile

 24. How does this image look different from the Lambert crater image? 

 Make several profi le plots across sections of the Crater Lake  
image. Try different tools for making the plot profi le selections. 
The Freehand Selection tool  can be used to try to fi nd a smooth 
route up and over the rim of the crater.

Since the pixel values represent elevations in this image, you get elevation 
profi les. If the pixel values represented temperature, you would get 
tem per a ture profi les, and so on.

 Make surface plots of several selections.

  25. Plot profi les across the crater usually include a long fl at section. What is 
the fl at part?

 Close all the open image and plot windows.

Part 3: Visualizing numeric data
Sometimes the pixel values in a given image represent mathematical 
func tions or matrices of numbers. Any spreadsheet of numbers can be 
displayed as a digital image. Histograms, den si ty plot pro fi les, and surface 
plots can make it easier to see the numerical patterns in the data.

 Open the 7 Paired Images folder. Open both the Stepped 
Ramp Right.tif and Ramp Right.tif and Ramp Right.tif Smooth Ramp Right.tif images in the Smooth Ramp Right.tif images in the Smooth Ramp Right.tif Pair 
1 folder.

 Choose Window > Tile to tile the images.

 26. What differences can you detect between the two images by looking at 
them?

 Activate and create a histogram for each image.

 27. What information does the histogram tell you about an image?

 Move your cursor horizontally and vertically across each image to 
dis cov er numerical patterns of the pixel values. Pixel values and 
coordinates are displayed in the status bar of the ImageJ window.

 Activate each image and create a horizontal profi le plot for each 
one.

 Activate each image and create a surface plot for each one.

 28. Briefl y describe what you see in each surface plot.

 29. Compare how profi le plots show numerical patterns in images to how 
surface plots show them.

Exploring digital data
Examine each of the images in the Pair 2, Pair 3, and Pair 4 folders. 
Predict what a resulting histogram, density plot profi le, and surface plot 
might look like for each image.

 Create a histogram, density plot profi le, and surface plots for each 
image. 

 30. Briefl y describe the pattern of the values in each image. How did the 
plots of each compare to your predictions?

 Close all images when you are fi nished.

On your own
Create and print a histogram, plot 
profi le, and surface plot for an image 
you create or scan. Write a brief 
description of what the graphs tell 
you about your image.

Crater Lake
surface plots
Explore Crater Lake by making 
surface plots of the DEM. For 
example, open the Elevation.lut
lookup table fi le. and turn on the 
wireframe option in the Analyze > 
Surface Plot window. 
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Advanced technique:
Density calibrating an image
Some of the images used in this lesson were density calibrated. This means 
that the raw pixel values were converted to some meaningful, real-world 
measurement through a mathematical equation. In this exercise, you will 
work through the density calibration procedure yourself.

 Open 8 Calibration.tif.8 Calibration.tif.8 Calibration.tif

Mammals and reptiles use different methods to regulate their body 
temperature. These images of a rat (top) and a snake (bottom) were taken 
with a special camera that records thermal infrared radiation. The images 
on the left show both animals at room temperature, and the images on the 
right show them after 15 minutes under a heat lamp.

In the image, dark blues represent lower temperatures, and reds and 
oranges are higher temperatures. The orange object entering the top of the 
frame at upper right is the hand of the person handling the animals. You 
can easily tell what is warmer and what is cooler based on the colors.

 31. Which animal’s body temperature appears to change the most from 
exposure to the heat lamp?

Wouldn’t it be nice to be able to measure the actual temperatures of the 
animals before and after the heat lamp? That would require converting the 
pixel values to temperature values. To do this, you need to have at least two 
known temperatures in the images.

Fortunately, we know that the room temperature when the images 
were made was 23°C, and we know that the human’s skin temperature 
was approximately 33°C. You can use these two known temperatures 
to calibrate the image. After calibration, you will be able to read the 
tem per a ture anywhere in the image, including the rat and the snake’s body 
surface temperatures.

 Choose Analyze > Clear Results to get rid of any previous 
measurements you have made.

 Choose Analyze > Set Measurements and turn off all the 
measurement options except Mean Gray Value. Set the number 
of decimal places to 1, and close the Set Measurements dialog 
box by clicking OK.

 Use one of the area selection tools to select a large sample of 
pixels from the person’s fi ngers in the upper right frame (see 
example at right).

 Press the M key to measure the mean (average) value of the pixels 
in the person’s fi ngers.

 Drag the selection outline from the fi ngers to an area of the 
background, and press M again to measure the mean value of the 
pixels that represent room temperature.

 Choose Analyze > Calibrate to open the calibration dialog box. The 
two mean pixel values you just measured should be listed in the 
left-hand column. Enter the corresponding known temperatures 
of the person (33) and the background (23) in the right-hand 
column. Choose the Straight Line option on the Function menu, 
and enter degrees C in the Unit box. Then click Unit box. Then click Unit OK.

What snake?
Many people question whether 
there’s really a snake present in 
the Before image. If you look very 
carefully in the lower left corner of 
the image, you will see a dark blue 
spot with a dark blue line extending 
below it. This is the snake’s nose 
and tongue, which are cooled 
as moisture is evaporated by the 
surrounding air. You should also be 
able to easily see the snake’s nose 
and tongue in the After image.

Sampling human skin 
temperaturetemperature
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The graph that appears shows the mathematical relationship between pixel 
value and tem per a ture. The computer uses the formula represented by this 
calibration line to convert the raw pixel values to temperature values. Once 
the image is calibrated, the pixel value in the status bar shows the actual 
temperature at the location under the cursor.

 Move your cursor around the image to determine the temperature 
of different areas.

 32. Use the area selection tools to sample and measure the surface 
temperature of the rat and the snake before and after they were 
exposed to the heat lamp. Use this information to complete Table 1.

Table 1

Animal

Body Surface Temperature (°C)

Before Heat Lamp After Heat Lamp

Rat

Snake

 33. What do these results tell you about the differences between how 
mammals and reptiles regulate their body temperatures?
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Data
Sheet

  More Than Numbers
 1. Look carefully at this image, and describe what you see.

 2. What do you think this image shows?

 3. What do you think the pixel values in the image represent?

 4. What are the highest and lowest elevations you can fi nd? What raw pixel values correspond to each 
elevation?

 a. lowest elevation = ___________  ( raw value = ______ )

 b. highest elevation = ___________  ( raw value = ______ )

 5. How many pixels in the image have a value of 8,200 feet?

 6. According to the histogram, what are the highest and lowest elevations in the image? (Reported as Max 
and Min in the histogram window.)

 a. lowest elevation = ________

 b. highest elevation = __________

 7. What elevation occurs most often in this DEM? (Reported as the Mode in the histogram window.)

 8. What is the average (Mean) elevation in the DEM?

Name(s)   ______________________________ Class  _________   Date  __________________
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 9. Where are the areas of highest elevation located?

 10. What are the lowest and highest elevations along the transect?

 a. lowest elevation = _________

 b. highest elevation = _________

 11. How does this profi le plot compare to the previous one you created?

 12. What kinds of landforms does this image show?

 13. Predict what a surface plot of this DEM would look like.

 14. Describe the shape of the land. Where are the Rocky Mountains?

 15. Compare this surface plot from the east to the one from the south. What details are visible in this view 
that you could not see before?

 16. How does a surface plot created from a small rectangular selection compare to one created from a larger 
rectangular selection?
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 17. What parts of the image have a calibrated value of -3°C? Do you think this value is the surface 
temperature in these areas?

 18. What sea surface temperature occurs most often?

 19. What do these graphs show you?

 20. What do the peaks and dips on the plots represent?

 21. What do you think the different widths of peaks and dips show?

 22. Before you make a profi le plot across the crater, make a sketch to predict how you think the plot will 
look.

 23. Sketch the resulting plot, and compare it to your prediction.

 24. How does this image look different from the Lambert Crater.tif image?Lambert Crater.tif image?Lambert Crater.tif
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  25.  Plot profi les across the crater usually include a long fl at section. What is the fl at part?

 26.  What differences can you detect between the two images by looking at them?

 27. What information does the histogram tell you about an image?

 28. Briefl y describe what you see in each surface plot.

 29. Compare how profi le plots show numerical patterns in images to how surface plots show them.

 30. Briefl y describe the pattern of the values in each image. How did the plots of each compare to your 
predictions?

 31. Which animal’s body temperature appears to change the most from exposure to the heat lamp?

 32. Use the area selection tools to sample and measure the surface temperature of the rat and the snake 
before and after they were exposed to the heat lamp. Use this information to complete Table 1.

Table 1

Animal

Body Surface Temperature (°C)

Before Heat Lamp After Heat Lamp

Rat

Snake

 33. What do these results tell you about the differences between how mammals and reptiles regulate their 
body temperatures?


