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Color by Number
Working with color images

Lesson

Reproducing color
Although digital imaging is not new, recent increases in image quality 
and decreased prices are converting more amateur and professional 
photographers from fi lm-based to digital technology. They are fi nding 
that digital images are easier and more economical to store, transmit, 
reproduce, and manipulate than the fi lm-based counterparts.

 Launch ImageJ, locate the 08 Color By Number folder, and open 
Balloon GS.tif.Balloon GS.tif.Balloon GS.tif

This image of a hot air balloon is an 8-bit grayscale image. (Note the “8-
bit” image type shown in the image window status bar, below the image 
window title bar.) This means that each pixel in the image is described by a 
number between 0 and 255, which represents the brightness measurement 
at that location in the scene.

 Move your cursor around on the image and watch the value 
displayed in the ImageJ status bar as you examine light and dark 
areas of the image.

 1. Does the pixel value in ImageJ represent “how much light” (black = 0 
and white = 255) or “how much black” (white = 0 and black = 255)?

 Open the Balloon RGB.tif image.Balloon RGB.tif image.Balloon RGB.tif

According to the image window status bar, the image type is now RGB, 
which stands for Red, Green, and Blue. If you look very closely at your 
color computer screen (with a mag ni fy ing glass or hand lens), you will see 
that the image is made of countless tiny red, green, and blue dots or bars. 
By mixing different amounts of these three colors of light, your com put er 
can create nearly any color of the rainbow.

 Move your cursor around this image and watch the changing 
pixel values in the ImageJ status bar.

Each pixel is now represented by three values instead of one. The RGB 
values are a kind of recipe, showing the amounts of red, green, and blue 
light that are mixed to produce the color of each pixel.

 2. Complete the following table by moving your cursor to any pixel in the 
image of the color shown, then write down that pixel’s red, green, and 
blue values.

Go to a pixel 
of this color

Record its RGB values

Red Green Blue

Red

Green

Blue

Understanding how different colors are formed is called color theory. A 
tool that is often used to help understand color theory is a color wheel.

image type

ImageJ Status Bar
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 Close the balloon images, and open the Color Wheel.tif image.Color Wheel.tif image.Color Wheel.tif

The three large circles represent the three main, or primary, colors: red, 
green, and blue.

 3. Predict what the “recipe” (R, G, and B values) for each of the primary 
colors will be:

 a. Red = ____, ____, ____

 b. Green = ____, ____, ____

 c. Blue = ____, ____, ____

   Check your predictions by moving your cursor to the red, green, 
and blue parts of the color wheel and examining the RGB values 
in the ImageJ status bar.

The areas where two primary colors overlap, or “mix,” are called the 
secondary colors. The table below shows the names of the three secondary 
colors and the primary colors that mix to form them.

 4. Based on the RGB recipes for the primary colors, complete the table 
by predicting the recipe for each of the secondary colors.

Mix these
Primary Colors

To get this
Secondary Color

RGB “recipe” of Secondary Color

Red Green Blue

Green + Blue Cyan

Blue + Red Magenta

Red + Green Yellow

   Check your predictions by moving your cursor to the cyan, 
magenta, and yellow parts of the color wheel and examining the 
RGB values in the ImageJ status bar.

In the center of the color wheel, all three primary colors mix together.

 5. What “color” do you get when you mix the maximum amount (255 
units) of Red, Green, and Blue light?

 6. What “color” would you get by mixing the minimum amount (0 units) 
of Red, Green, and Blue light?

Color separations
In the printing industry, color pictures are created the same way as on a 
computer screen—by printing pat terns of small dots using three colors of 
ink. Printers must fi rst sep a rate color pic tures into three separate im ag es, 
which are used to make three printing plates, one for each color of ink.

 Choose Image > Color > RGB Split.

 Choose Window > Tile.

The color wheel image has been split into three separate images or 
channels. Each of these channels is a grayscale image with pixel values 
ranging from 0 to 255. The title bar of each image contains the original 
image name followed by the color channel, in parentheses. [For example, 
Color Wheel.tif (red).]

 Examine the pixel values of the three color channel images.

More about
color printing
Reproducing color using ink on 
paper is a little diff erent than 
making color pictures with glowing 
primary color dots on a television or 
computer screen. If you look closely 
at a color picture in a magazine, you 
will see patterns of tiny dots of cyan, 
magenta, and yellow ink.

Mixing these three colors produces 
muddy-looking shadows, so printers 
add a layer of black ink dots to 
give the images more “snap.” This 
four-color printing process is called 
CMYK. (Cyan, Magenta, Yellow, and 
Black. The “K” is used because “B” 
stands for the primary color Blue.) 
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The pixels in the three channels of the color wheel image are all either 
minimum (0) or maximum brightness (255). Next, you will explore what 
happens to the color when the pixel values of each channel are something 
other than 0 or 255.

 To fi ll one or more of the circles of the color wheel channels with a 
different brightness value:

 • Double-click the Color Picker tool  to choose a new  to choose a new 
brightness level (shade of gray) from the grayscale on the left 
side of the color picker window. (Remember the value you 
choose.) Close the Color Picker window.

 • Use the Wand (tracing) tool  to click inside the circle you  to click inside the circle you 
want to “re-color.”

 • Choose Edit > Fill, or press Ctrl-F (the F key on a Mac) to fi ll the 
selected area with the new brightness value.

 7. You have just changed the “recipe” for the color in the center of the 
color wheel. What are the “new” RGB values for this color?

  Red = _______   Green = _______   Blue = _______

 8. Predict the new color that this new RGB recipe will create. (Describe it 
in your own words.)

To see what your new color looks like, you will combine the three separate 
color channels back into a single, composite RGB image.

 Choose Image > Color > RGB Merge..., and click OK.

 9. Calculate the number of different colors that you can produce using 8 
bits (0 to 255) for each of the three color channels. Since there are 256 
possible values for each of three colors, the total number of possible 
colors is:

256 x 256 x 256 = __________________________ colors!

 Close the Color Wheel image(s), and open the three images in 
the Blocks folder, in order (red fi rst, then green, then blue).

 Choose Image > Stacks > Convert Images to Stack.

You have seen how to create a color composite image by merging three 
separate grayscale images. You can also create a color composite image 
from a three-slice stack, where the slices are in Red-Green-Blue order. 
Before you create the color composite from these images, you will try to 
predict the color of each block.

 Using the slider control at the bottom of the stack window, 
fl ip through the stack. Use the brightness of the blocks in each 
channel to predict the color of each block.

 10. Predict the color of:

 a. the “T” block.

 b. the “C” block.

 c. the “I” block.

 Choose Image > Color > Convert Stack to RGB to convert the stack 
to a color composite image, and check your predictions.

 Close the color blocks stack and stack (RGB) images.

RGB merge options
The three color channel images 
should already be assigned to the 
correct color. If you want to keep 
copies of the original color channels 
open when you create the color 
composite, check the Keep source 
images option.

In the Color 
Picker (CP) 

window, 
click a grayscale 

“color” to set 
the fi ll color.
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 Open the Rainbow Bridge Stack.tif image.

This image is another RGB stack. Before you convert it to a color RGB 
image, you will practice predicting colors from the separate channels one 
more time.

 Using the slider control at the bottom of the stack window, fl ip 
through the stack.

 11. On the grayscale version of the image below, circle and label three 
areas—one that should appear red, one that should be green, and 
another that should look blue in the color composite version.

 Choose  Image > Color > Convert Stack to RGB to create an RGB 
color image, and use it to check your predictions.

Indexed color
Not all color images are created equally. The RGB images you have been 
looking at so far store the picture by saving the RGB recipe consisting 
of three 8-bit numbers for each and every pixel in the image. While this 
reproduces colors very accurately, you pay the price for storing so much 
information. RGB color image fi les are three times as large as a grayscale 
image of the same scene.

One solution to this color image fi le size dilemma is to reduce the number 
of possible colors in the image. ImageJ gives you the option to create and 
save color images with up to 256 colors (including black and white), creating 
a color image that’s the same size as the grayscale version. The colors are 
saved in a color lookup table, and the image is stored as pixel values from 0 
to 255 that are indexed to the location of the appropriate color in the lookup 
table. This color image mode is called indexed color, or indexed color, or indexed color 8-bit color. Next, you 
will create an 8-bit color version of the Rainbow Bridge image.

 Choose  Image > Duplicate... and rename the copy of the image 
Rainbow Bridge Indexed Color.
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 Choose Image > Type > 8-bit Color, set the number of colors to Image > Type > 8-bit Color, set the number of colors to Image > Type > 8-bit Color
256, and click OK. Note the 8-bit Color image type in the image 8-bit Color image type in the image 8-bit Color
window’s status bar.

Arrange the two windows side by side. The 8-bit color image does not look 
too bad, but take a closer look.

 Use the Magnifying Glass tool  to examine both images more  to examine both images more 
closely. (On a Mac, you can use the + and - keys to magnify or 
reduce the image.)

 12. Compare the quality of the RGB color and the 8-bit color version of the 
Rainbow Bridge image.

There are other differences between the two color image types that aren’t 
so obvious. For example, let’s say you decided that the images are too dark 
and you want to lighten them a little. (You will need to repeat the following 
steps for both images. Click on an image window to work with that image.)

 Double-click  to zoom back out to see the entire image. to zoom back out to see the entire image.

 Starting with the RGB color version, choose Image > Adjust 
> Brightness/Contrast. Adjust the Minimum, Maximum, 
Brightness, and Contrast sliders until you are happy with the 
image, then click the Apply button.

 Repeat the above process with the 8-bit color image.

 13. Describe what happens.

Changing the brightness and contrast of an RGB color image changes 
the color recipe of the pixel values, but does not drastically alter the 
appearance of the image. In other words, a red pixel is still a red pixel. 
However, adjusting the brightness and contrast of an 8-bit color image re-
indexes each pixel to a completely different color on the lookup table.

 14. Describe at least two advantages and two disadvantages of RGB color 
and 8-bit color images.

 Close all open image windows.

Color for science
Most cameras used for scientifi c purposes record only the brightness 
information of the scene they are aimed at. To create color images, grayscale 
(brightness) pictures are taken through colored fi lters. These images are 
then combined into a color composite by assigning each image to the 
appropriate color channel. To create a true-color picture, images are taken true-color picture, images are taken true-color
through red, green, and blue fi lters, which are then assigned to the red, 
green, and blue channels, respectively. When images taken through a fi lter 
are assigned to a color channel that does not match the fi lter, the result is a 
false-color image. While these images may look strange to us, they can be 
very useful in helping to understand the information the images contain.

True and false color in ImageJ
You may have noticed that ImageJ’s RGB Merge dialog box allows you 
to assign any image to any color channel. First, you will “color inside the 
lines” and create a true-color version of the image.

 Open the Landsat folder, and open all seven images in the Santa 
Cruz Valley, AZ folder.

Lots o’ colors!
Scientifi c cameras may contain two, 
three, or more fi lters. Some imaging 
systems actually record in hundreds 
or even thousands of diff erent 
wavelengths!

Landsat Bands
Band 1 (blue) ....................... 0.45-0.52 µm

Band 2 (green) .................... 0.52-0.60 µm

Band 3 (red) .......................... 0.63-0.74 µm

Band 4 (near IR) .................. 0.76-0.90 µm

Band 5 (mid IR) ................... 1.55-1.75 µm

Band 6 (thermal IR) .......... 10.4-12.5 µm

Band 7 (mid IR) ................... 2.08-2.35 µm
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 Choose Image > Color > RGB Merge…, and use the popup menus 
to assign the Santa Cruz Valley TM 3.tif to the red channel, Santa Cruz Valley TM 3.tif to the red channel, Santa Cruz Valley TM 3.tif
Santa Cruz Valley TM 2.tif to the green channel, and Santa Cruz Valley TM 2.tif to the green channel, and Santa Cruz Valley TM 2.tif Santa 
Cruz Valley TM 1.tif to the blue channel. Check the Cruz Valley TM 1.tif to the blue channel. Check the Cruz Valley TM 1.tif Keep 
source images option so that you don’t have to re-open the 
original images again.

Since the fi lters used by the Landsat camera for bands 3, 2, and 1 really 
were red, green, and blue, the scene is reproduced approximately as your 
eyes would see it.

Scientists use a simple shorthand to describe how the bands are assigned 
to color channels—they write them in RGB order. Thus, true color Landsat 
images are described as 3,2,1 (RGB).

 Close ONLY the RGB composite color image window, and leave 
the seven Landsat band images open.

False color
What if you “break the rules” and assign the bands to the “wrong” 
channels? You can’t break anything, so try it!

 Choose Image > Color > RGB Merge…, and use the popup menus 
to create a 4,3,2 false-color image. (Remember to check the Keep 
Source Images option.)

 15. How does vegetation appear in a 4,3,2 false-color image?

 Experiment with creating false-color images with different band 
assignments. (With 7 bands, there are a total of 210 different ways 
to assign the bands to color channels!) 

You can even assign the same band to two, or all three color channels.

 16. Predict what an RGB composite image with the same band assigned to 
all three channels would look like.

 17. Test your prediction, and describe the results.

 When you have tried out all 209 different false-color composites 
(or are tired of making them), close all seven of the Landsat band 
images.

Creating 3-D stereo images
The technique of creating color composite images can also be used to 
produce three-dimensional or “stereo” images. To create the illusion of 
depth, slightly different images rep re sent ing two separate viewpoints of an 
object must be sent to the brain.

 Open the two images in any of the subfolders inside the Mars 
Rover 3D folder.

These images were taken by the twin rovers, Spirit and Opportunity, that Opportunity, that Opportunity
landed on and explored the surface of Mars in 2004.

 Choose Image > Stacks > Convert Images to Stack.

 Use the slider control at the bottom of the stack window to fl ip 
back and forth between the two views.

 18. What appears to happen to the scene of the surface of Mars?

Image registration
Since it takes time to move a 
diff erent fi lter in front  of the lens, 
images created through fi lters are 
not taken at the exact same time. 
This means that if the subject or the 
camera is moving, the images will 
not be registered. That is, they will  
not show exactly the same scene.  
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 Choose Image > Stacks > Convert Stack to Images.

When you unstack the images, they are now labeled 001 and 002, instead 
of Left and Left and Left Right. 

One way to create a 3-D effect is to combine the left and right eye views in 
the same image window, assigning a different color to each view. You then 
control which view is seen by each eye using colored fi lters, and your brain 
is fooled into believing it sees three dimensions (height, width, and depth).

There are two possible ways to assign the views to the red and blue color 
channels, so you will create two versions of the 3-D image and compare 
them to see which produces the best results. If you don’t assign anything 
to the green channel the image looks too dark, so you will assign the same 
view to both the green and blue channels.

 Create the fi rst 3-D scene. Choose Image > Color > RGB Merge…, 
and use the popup menus to assign the Left (or 001) image to the 
red channel and the Right (or 002) image to both the green and 
blue channels. Check the Keep Source Images box, then click OK.

You can reverse the channels assigned to each image to create a second 
3-D image for comparison. 

 Choose Image > Color > RGB Merge… again, and use the popup 
menus to assign the Right (or 002) image to the red channel and 
the Left (or 001) image to both the green and blue channels.

 Put on your red and blue glasses, and look at the images. It may 
take several seconds before your eyes relax enough to allow the 
images to overlap.

 19. Which of the two channel assignments you tried produces the image 
with the best 3-D effect?

 20. 3-D images are fun to look at, but how do you think they would be 
useful to a scientist?

  When you have fi nished creating 3-D images, close all open 
images. 



144 Discovering Image Processing
©2006 The Center for Image Processing in Education and 

portions ©1998 Arizona Board of Regents.
Limited classroom reproduction rights are granted earlier in this work.



 Color by Number 145
©2006 The Center for Image Processing in Education and 

 Color by Numberportions ©1998 Arizona Board of Regents. Color by Number Color by NumberLimited classroom reproduction rights are granted earlier in this work. Color by Number

Data
SheetColor by Number

 1. Does the pixel value in ImageJ represent “how much light” (black = 0 and white = 255) or “how much 
black” (white = 0 and black = 255)?

 2. Complete the following table by moving your cursor to any pixel in the image of the color shown, then 
write down that pixel’s red, green, and blue values.

Go to a pixel 
of this color

Record its RGB values

Red Green Blue

Red

Green

Blue

 3. Predict what the “recipe” (R, G, and B values) for each of the primary colors will be:

 a. Red = ____, ____, ____

 b. Green = ____, ____, ____

 c. Blue = ____, ____, ____

 4. Based on the RGB recipes for the primary colors, complete the table by predicting the recipe for each of 
the secondary colors.

Mix these
Primary Colors

To get this
Secondary Color

RGB “recipe” of Secondary Color

Red Green Blue

Green + Blue Cyan

Blue + Red Magenta

Red + Green Yellow

 5. What “color” do you get when you mix the maximum amount (255 units) of Red, Green, and Blue light?

 6. What “color” would you get by mixing the minimum amount (0 units) of Red, Green, and Blue light?

 7. You have just changed the “recipe” for the color in the center of the color wheel. What are the “new” 
RGB values for this color?

  Red = _______   Green = _______   Blue = _______

 8. Predict the new color that this new RGB recipe will create. (Describe it in your own words.)

 9. Calculate the number of different colors that you can produce using 8 bits (0 to 255) for each of the three 
color channels. Since there are 256 possible values for each of three colors, the total number of possible 
colors is:

256 x 256 x 256 = __________________________ colors!

Name(s)   ______________________________ Class  _________   Date  __________________
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 10. Predict the color of:

 a. the “T” block.

 b. the “C” block.

 c. the “I” block.

 11. On the grayscale version of the image below, circle and label three areas—one that should appear red, 
one that should be green, and another that should look blue in the color composite version.

 12. Compare the quality of the RGB color and the 8-bit color version of the Rainbow Bridge image.

 13. Describe what happens.

 14. Describe at least two advantages and two disadvantages of RGB color and 8-bit color images.

 15. How does vegetation appear in a 4,3,2 false color image?
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 16. Predict what an RGB composite image with the same band assigned to 
all three channels would look like.

 17. Test your prediction, and describe the results.

 18. What appears to happen to the scene of the surface of Mars?

 19. Which of the two channel assignments you tried produces the image 
with the best 3-D effect?

 20. 3-D images are fun to look at, but how do you think they would be 
useful to a scientist?


