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The ImageJ user interface
The ImageJ user interface is nearly identical for Windows and Macintosh 
operating systems, except for the location of the menu bar.

Windows
 Under Windows, the menu bar is at the top of the ImageJ window.

Macintosh
On the Macintosh, the menu bar is at the top of the screen, separate from 
the ImageJ window.

The ImageJ toolbar
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Need to know more?
For additional information about 
ImageJ’s tools and menus, refer to 
the online user’s guide at:

http://rsb.info.nih.gov/ij/docs/

This guide can be opened from 
within ImageJ by choosing Help > 
Online Docs...

ImageJ updates
ImageJ is constantly being updated 
and improved. Updating your copy 
of ImageJ from the version included 
with this package may result in 
changes to the user interface. The 
capabilities of the program may 
also change signifi cantly, and lesson 
instructions and results may need to 
be modifi ed.

You can have access to the latest 
tools and functions while retaining 
compatibility with these materials by 
installing multiple copies (versions) 
of ImageJ on your computer. Each 
copy can be launched and run 
independently.
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Drawing tools
The blank buttons  will be replaced 
by additional tools in future versions 
of ImageJ.
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Tool descriptions

Area selection tools
The area selection tools allow you to select an area, or region of interest
(ROI), of the image using a rectangle, oval, polygon, or freehand shape, 
or some combination of these shapes. To move a selection, click and drag 
within the selection outline, or use the arrow keys to nudge the selection 
one pixel at a time in any direction. The selected areas can be edited, 
enhanced, analyzed, outlined, fi lled, or copied using menu commands and 
keyboard shortcuts. As you make a selection, the location and dimensions 
of the selection are displayed in the ImageJ status bar.

To measure the selected area, press M (measure); to outline the selected 
area using the foreground color, press D (draw); to fi ll the selected 
region with the foreground color, type F (fi ll); and to fi ll the area with the 
background color, press the Backspace key (Delete key on Macs).

To subtract from an existing selection using any of these tools, hold down 
the Alt (Win) or Option (Mac) key as you make the selection. To add to 
an existing selection, hold down the Shift key as you make additional Shift key as you make additional Shift
selections. Note: When adding selections with the rectangle and oval tools, 
you can avoid constraining your selection to a square or circle by releasing 
the Shift key before you release the mouse button.Shift key before you release the mouse button.Shift

Rectangle
  When creating rectangular selections, click on one corner of the 

area and drag to the opposite corner. Hold the Shift key down to Shift key down to Shift
constrain the selection to a square. You can modify the selection 
by dragging any of the eight square handles around the edges 
of the selection. In addition, you can use the Alt (Win) or Alt (Win) or Alt Option
(Mac) key combined with the Arrow keys to change the height 
and width of the selection by one pixel at a time.

Oval
  Creates elliptical selections that can be moved and resized using 

the same methods as rectangular selections.

Polygon
  Creates irregularly shaped selections composed of a series of line 

segments. Click at the end of each segment, then click in the small 
box at the starting point to complete the selection. Alternatively, 
you can double-click at the end of the next-to-last segment, and 
ImageJ will automatically complete the last segment. To modify 
the polygon, drag the square handles at each vertex. To delete a 
vertex, hold down the Alt (Win) or Option (Mac) key and click 
on the vertex. To add a vertex, hold down Shift and click on a Shift and click on a Shift
segment.

Freehand area
  The freehand area tool lets you drag the cursor to create 

irregularly shaped selections. The area will automatically close 
when you release the mouse button. To edit a freehand area, 
choose Edit > Selection > Fit Spline. The resulting selection can 
then be edited using the same methods as the polygon selection 
tool.

Setting line width
To set the drawing line width for all 
of the selection tools, double-click 
any of the line selection tools and 
set the desired width in pixels.

Changing the selection 
outline color
By default, ImageJ uses a yellow line 
to outline selection. This may not 
always be appropriate, such as when 
selecting against a light (or even 
yellow) background. To change the 
selection outline color, choose Edit 
> Options > Colors... and choose 
a diff erent color.

Editing selections
with handles

To modify a selection with editing 
handles (the small squares along the 
selection line), drag a handle to the 
desired location.

With polygon selections, you can 
Alt-(Win) or Option-(Mac) click on click on click
a handle to delete it, and Shift-click 
on a handle to add a new handle.

To modify a selection with editing 
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Line selection tools
The line selection tools create straight, segmented, or freehand line 
selections. Drag or use the arrow keys to move line selections, and drag 
handles to edit the selection. To measure the selected line, press M
(measure); to draw the selected line using the foreground color, press D
(draw) or F (fi ll); and to draw the line with the background color, press the 
Backspace key.

Caution: Regardless of the shape selected, measurements made 
with the line selection tools include only the pixels under or under or under behind
the line. Using the segmented or freehand line selection tools to 
select and measure areas will produce incorrect results.

Straight line
  Click, drag, and release the mouse button to defi ne the endpoints 

of a line selection. Hold down the Shift key while dragging to Shift key while dragging to Shift
constrain the line to vertical or horizontal. While dragging, the 
length and angle of the line is displayed in the status bar.

Segmented line
  Use the segmented line tool to select lines made of straight line 

segments. Click once at the end of each segment, and double-click 
at the fi nal endpoint. If double-clicking is diffi cult, you can also 
click in the box at the beginning of the line. (Unlike the polygon 
area tool, the segmented line tool cannot “close in” an area.)

Freehand line
  Use the freehand line tool to create irregular line selections by 

dragging on the image. To convert the freehand line to an editable  
curved line, choose Edit > Selection > Fit Spline.

  Angle tool
The angle tool selects angles on images using three clicks—the fi rst defi nes 
one leg, the second the vertex, and the third the other leg. After the fi rst 
click, the status bar displays the angle of the cursor, measured ±180° 
relative to the 3 o’clock position. After the second click, the status bar 
displays the interior angle (≤ 180°) of the angle defi ned by the fi rst leg and 
the current cursor position.

To edit an angle, drag any of the three handles. As you drag a handle, the 
changing angle measurement is displayed in the status bar.

  Point selection tool
Click on the image with the point selection tool to select, mark, and record 
locations on the image. To select multiple points, hold down the Shift key Shift key Shift
while clicking on each location. Drag a point to move it, and Alt-click (Win) 
or Option-click (Mac) a point to delete it.

In Auto Measure mode, each click on the image records the coordinates 
and brightness value of the pixel in the Results window. Double-click the 
point selection tool button to turn on the auto-measure mode option or set 
the mark width. If a mark width greater than zero pixels is selected, a point 
will automatically be drawn each time you click on the image. To draw 
points without measuring, turn off Auto Measure, select a point, and 
press the D (draw) key.

Using the Angle tool
Selecting with the angle tool 
requires three clicks: (1) the fi rst leg, 
(2) the vertex, and (3) the second leg.

1

2
3

Point tool optionsPoint tool options

Line tool areas
Although it appears possible to 
select an area using the freehand 
line tool, the area reported when 
you measure the selection is not
the area enclosed by the selection. 
Rather, it is the area of the pixels 
crossed by the selection line, 
shown here in black. Always use the 
area selection tools to select and 
measure areas.
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Foreground
color

BackgroundBackground
color

Foreground &
background colors
The current foreground and 
background colors are shown on the 
color picker tool button. Double-
click this button to set these colors.

Note: with RGB color images, pixel values are reported on the status bar 
as separate red, green, and blue channel values. The value recorded in the 
Results window is the average of the R, G, and B values (not very useful!).

  Wand (tracing) tool  Wand (tracing) tool
The wand tool automatically fi nds the edge of an object and traces its The wand tool automatically fi nds the edge of an object and traces its 
shape. It works best with high contrast images. Place the wand to the left of 
an edge, and click to have ImageJ trace along the edge of the object until it 
returns to the starting point.

An object is defi ned as a cluster of pixels having the same color or value. 
ImageJ does not currently have the ability to defi ne an object based on a 
range of pixel values.

  Text tool

The text tool is used to add text labels to images. Adding text is a simple 
four-part process:

 • Click at the text’s desired location.

 • Type the text. This creates a selection shaped like the desired text, 
which expands as you type. Type Return (Enter on some keyboards) 
to create multi-line text. Use the backspace key to edit the text.

 • Drag the text selection, or use the arrow keys to move the selection to 
the proper location.

 • Draw the text using Ctrl+D or by choosing Edit > Draw.

Double-click the text tool button to select the text font, size, and style. Text 
draws in the foreground color defi ned in the color picker tool button.

Note: Drawing text on an image destroys data by replacing the original 
pixel values with the foreground color. Text cannot be edited after it is 
drawn, but it can be deleted by immediately choosing Edit > Undo. After 
this, the only way to delete text is to choose File > Revert, which will undo 
all changes made to the image since it was last saved.

  Magnifying glass (zoom) tool
To zoom in or magnify the image up to 32×, click on the image or press To zoom in or magnify the image up to 32×, click on the image or press 
the + key repeatedly. To zoom out or reduce an image down to 1/32×, you 
may right-click, Option-click (Mac), Alt-click (Win), or press the - key 
repeatedly. Double-clicking 

Option-click (Mac), 
 returns the image to full size. returns the image to full size.

  Scrolling tool

This tool allows you to move the image within its window if it is larger than 
the window. While using any other tool except the text tool, you can quickly 
toggle on the scrolling tool by holding down the space bar.

  Color picker tool
This tool sets the foreground drawing color or text color by “picking up” This tool sets the foreground drawing color or text color by “picking up” 
colors from images with the cursor. Colors may also be picked up from 
the CP (color picker) window by double-clicking the color picker button. 
Alt-click (or Option-click) in the CP window to change the background 
color. The eyedropper in the color picker tool button shows the current 
foreground color while the frame around it shows the background color.

Selecting areas using
the wand tool

Image of leaf selected using the 
wand (tracing) tool. To isolate the 
background, the contrast had to 
be increased using the Brightness 
and Contrast control panel, and 
the contrast change permanently 
applied to the image.

Text tip
To add color labels to grayscale or 8-
bit color images, convert the image 
to RGB color fi rst, using Image > 
Type > RGB.



22 Discovering Image Processing
©2006 The Center for Image Processing in Education.

Limited classroom reproduction rights are granted earlier in this work.

Caution: Even though colors appear in the color picker tool, 
accurate colors are only available when working with RGB color 
images. On 8-bit color images, drawing colors will not match the 
foreground and background colors; on grayscale images, actual 
drawing colors will be shades of gray.

Drawing tools
In addition to drawing and fi lling shapes using the selection tools, 
ImageJ provides familiar drawing tools like those found in most graphic 
applications. The actual tools are provided through a macro fi le that ImageJ 
loads automatically at startup. If these tool buttons do not appear on the 
toolbar, you may need to install or replace this fi le.

Remember that the drawing tools permanently modify pixel values, and 
that scientifi c analysis may not be valid if the image has been modifi ed in 
any way.

  Pencil tool
  The pencil tool draws points and lines in the foreground color. Double-

click the tool button to set the diameter of the pencil tool.

  Paint brush tool
  The paint brush tool draws with a circular brush, using the foreground 

color. Double-click the tool button to set the diameter of the paintbrush 
tool.

  Eraser tool
  The eraser tool draws with a circular shape, using the background 

color. Double-click the tool button to set the diameter of the eraser 
tool.

  Flood fi ll tool
  The fl ood fi ll tool fi lls the pixel you click on and any adjacent pixels 

having the same value with the foreground color. Double-click the tool 
button to set the foreground color.
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Need to know more?
For a more detailed description of 
ImageJ’s tools and menus, refer to 
the online user’s guide at:

http://rsb.info.nih.gov/ij/docs

This guide can be opened from 
within ImageJ by choosing Help > 
Online Docs...

ImageJ menus

File menu
The File menu allows you to create 
new image windows, open existing 
image fi les, as well as print and save 
image fi les.

Edit menu
The Edit menu provides standard 

editing functions such as undo, cut, 
copy, and paste. In addition, it off ers 

the powerful Paste Control feature, 
drawing commands, and selection 

and program options.

Image menu
The Image menu provides 
functions for manipulating 
the display of images.

Process menu
The Process menu includes 

powerful data fi ltering and 
manipulation tools.

Analyze menu
The Analyze menu off ers a variety of 
tools and functions for measuring and 
representing image data.

Plugins menu
The Plugins menu provides 

access to ImageJ plugins 
and macros that expand the 

power and convenience of 
the application.

Help menu
The Help menu links to the 
ImageJ Web site and online 

documentation.

Window menu
The Window menu allows the user 
to control the placement of image 
and program windows in ImageJ.


